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❗ EVERYTHING BELOW IS FOR WINDOWS SYSTEMS
ONLY

GenP & M0nkrus only work on Windows 10 and 11.

ARM architecture is not supported.

We do not support macOS, Linux or modified Windows versions.

Please read the guides thoroughly before taking any action, as well as posting repeated
questions...

We aim to prolong your trial phase longer than usual so you can practice more before you are
professionally and financially capable of going the traditional route.

If you find any issues or areas for improvement in the information provided or the way the guides are
presented, please message the mods with specific details or constructive criticism!
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In full desktop mode, it is located in the side banner on the right.

In mobile mode, it is located at the top of the guide.

Guide Images

Images should be visible on all devices, but they might not display on some mobile devices. For full
visibility, use desktop mode.

 

 

⭐ DOWNLOAD DIRECTORY
Any link or text with Strikethrough is either outdated, or broken

CC + GenP - (scroll to guide #2)

🔗 Creative Cloud (CC) - Adobe Download - Always use this one first as priority

🔗 Creative Cloud (CC) - Adobe Alternative Download - Use if have issues with Adobe Download

🔗 Creative Cloud (CC) - Backup Download - Only use if have issues with both Adobe Downloads
above

🔗 GenP 3.4.2 CGP - (Previous Version, Supports Patching Fresco & XD)

🔗 GenP 3.5.0 CGP - Current Updated Version

🔗 GenP 3.5.0 CGP - Current Updated Version - MIRROR 1

🔗 GenP 3.5.0 CGP - Current Updated Version - MIRROR 2

NOTHING IS WORKING / FULL CLEANING - (scroll to guide #4)

🔗 Adobe Creative Cloud Cleaner Tool

🔗 Revo Uninstaller (Optional)

Monkrus Individual / Collection - (scroll to guide #7)

🔗 qBittorrent

🔗 Monkrus Individual - Acrobat PRO (get only x64 versions only)

🔗 Monkrus Individual - After Effects

🔗 Monkrus Individual - Animate (PRO version doesn't work)
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🔗 Monkrus Individual - Audition

🔗 Monkrus Individual - Character Animator (PRO version doesn't work)

🔗 Monkrus Individual - Illustrator

🔗 Monkrus Individual - InDesign

🔗 Monkrus Individual - Lightroom Classic

🔗 Monkrus Individual - Media Encoder (Must match same version of Premiere / After Effects to
properly work)

🔗 Monkrus Individual - Photoshop

🔗 Monkrus Individual - Premiere Pro

🔗 Monkrus Individual - Speech to Text Add-on for Premiere (Must be compatible with same version
of Premiere, check the description in the tracker for compatibility with Premiere versions)

🔗 Monkrus Individual - Substance

🔗 Monkrus Individual - XD

🔗 Monkrus Collection (All Apps)

 

 

► Guide #1 - How to whitelist files
On Windows Defender:

Windows 11:

Windows 11 Official Instructions

1. Click the Windows key.

2. Write "Settings".

3. Go to Privacy & security > Windows Security > Virus & Threat Protection .

4. Under Virus & threat protection settings, click "Manage settings".

5. Under Exclusions, click on "Add or remove exclusions".

6. Locate the extracted GenP folder and click "Select folder".

Note: A folder exclusion will apply to all subfolders within the folder as well.

Windows 10:
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Windows 10 Official Instructions

1. Click the Windows key.

2. Write "Settings".

3. Go to Update & Security > Windows Security > Virus & Threat Protection .

4. Under Virus & threat protection settings, click "Manage settings".

5. Under Exclusions, click on "Add or remove exclusions".

6. Locate the extracted GenP folder and click "Select folder".

Note: A folder exclusion will apply to all subfolders within the folder as well.

 

On Google Chrome:

1. On an empty page press "CTRL+J to bring up your "Download history tab".

2. Click on "More Actions" (three vertical dots) and choose "Download dangerous file".

Trust GenP and add to Allowed to show [download] insecure content:

1. In Chrome Settings go to Privacy and Security > Site Settings > Additional Content 
Settings > Insecure content .

2. Click "Add" on Allowed to show insecure content, add the site address for GenP and click "Add".

Trust Specific Site Only:

1. Click "View site information" in the address bar (icon on left side of address).

2. Click "Site Settings", scroll down to "Insecure Content" and change it to "Allow".

 

On used antiviruses (AV):

Norton

Norton Official Instructions

Norton Video

Avast

Avast Official Instructions

Avast Video

Malwarebytes

Malwarebytes Official Instructions
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Malwarebytes Video

Mcafee

Mcafee Official Instructions

Mcafee Video

Bitdefender

Bitdefender Official Instructions

Bitdefender Video

 

 

☠️ Guide #2 - Dummy Guide for First Timers GenP (CC +
GenP)

[No Video Tutorial for Revamp 2025 yet]

DOWNLOADS / TOOLS NEEDED

🔗 Creative Cloud (CC) - Adobe Download - Always use this one first as priority

🔗 Creative Cloud (CC) - Adobe Alternative Download - Use if have issues with Adobe Download

🔗 Creative Cloud (CC) - Backup Download - Only use if have issues with both Adobe Downloads
above

🔗 GenP 3.5.0 CGP - Current Updated Version

🔗 GenP 3.5.0 CGP - Current Updated Version - MIRROR 1

🔗 GenP 3.5.0 CGP - Current Updated Version - MIRROR 2

 

⛔ Generative Fill or AI online features DO NOT WORK

You can forget about it without a valid subscription or active trial (7 days). It’s been adapted into the
monthly credits service for valid subscription users (pay-wall). Therefore, it's gone forever.
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⚠️ Any ongoing new changes or fixes might not be immediately reflected in either the tools or
the written guides (we’re people and have lives, too), but we will try our best to update it ASAP.

 

Instructions to install CC + GenP

 

1. Download & Install Creative Cloud

Always use Adobe Download first as priority when you require Creative Cloud.

Have issues with not being able to download Creative Cloud using Adobe Download, switch to using
Adobe Alternative Download and obtain Creative Cloud from "Windows | Alternative downloads"
dropdown, if still failing to download for you even then, you can make use of the Backup Download.

If you get a .dmg file when you download Creative Cloud, it's likely because you're using Opera as your
web browser.

Adobe has issues identifying the browser used after calling Opera's user agent string through http,
therefore it completely ignores any platform info and just falls back to providing a .dmg file, to avoid this
you need to use a different browser.

Adobe Account Required for Sign-In During Creative Cloud Installation:

This requirement by Adobe cannot be avoided and ensures you have access to your subscription and all
associated services.

You can create a free account using your email or a temporary email (search "temp mail" on Google; any
should work), or use an existing account. However, do not use an account with ongoing or previous
subscriptions, or one that has ever started a trial (to avoid problems).

If you use a temporary email, make sure that you keep the temporary email inbox open long enough to
receive your email verification from Adobe, otherwise, you might have to create a new free account later
on if you are asked to verify your account and no longer have access to the temporary email.

During Install:

Ensure that you are logged into your device as an Administrator, if you are using a standard, guest,
Microsoft, or local account, switch to an Administrator account.

If shown - Account authentication window - Quit your install and change settings to avoid issues
during installation as here:

User Account Control (UAC) must be turned on, run Creative_Cloud_Set-Up.exe  as Administrator.

If shown - Do NOT install Adobe Genuine Service (AGS) - if not shown, continue anyway.
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Once installed go to Menu > File > Preferences  and in the "General" tab disable the following:
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Launch Creative Cloud at login;

Run Creative Cloud in the background after closing;

Automatically keep Creative Cloud up to date.

Once that is done go Menu > File > Quit Creative Cloud

 

2. Download the latest GenP in the guide - extract ALL contents from zip

It is advised to fully disable your used antivirus as it can sometimes block the GenP download.

Once you have the GenP.v3.5.0-CGP.zip  file, right-click and "Extract All" contents.

 

⚠️ Possible Problem & Solution - Step 2

⚠️ Antivirus programs may sometimes block the download. You should disable your used antivirus
before downloading. This will fix the issue of GenP not being able to be downloaded.

⚠️ Antivirus programs may sometimes delete or move files into quarantine. You can either whitelist
GenP as safe or disable your used antivirus before extracting. This will fix the issue of .exe not showing
in the folder after extraction.

Log InSkip to main content

4/1/25, 11:13 AM GenP

https://www.reddit.com/r/GenP/wiki/redditgenpguides/?rdt=46251 9/52

https://www.reddit.com/
https://www.reddit.com/login/


Whitelisting GenP as safe is always the preferred option to use, however you can just disable your used
antivirus for a temporary period if you prefer, always remembering to re-enable it once done afterwards.

Disabling Windows Defender: Go to Settings > Privacy & security > Windows Security > 
Virus & Threat Protection  and toggle off the options there, if it is still not allowing it, you also need
to go to Settings > Privacy & security > Windows Security > App & browser control  and
toggle off the options in Reputation-based protection.

If using other antiviruses (AV) and unsure how to do it yourself, you will need to view the relevant
instructions from the website of your used antivirus provider, we only provide links for the preferred
option of whitelisting as in Guide #1 - How to whitelist files.

For Windows 11 users who have Smart App Control turned on, unfortunately there is no current way to
bypass this protection for individual apps. The only way to sort this is to turn off Smart App Control in the
Smart App Control Settings by going here Settings > Privacy & security > Windows Security > 
App & browser control > Smart App Control . However, note that this is not something that you
can simply turn on and off, if you turn it off and want it back on then you will need to reinstall Windows.
Read more about it here Smart App Control.

 

3. Patch Creative Cloud with GenP

Note that you should be running GenP as Administrator.

You are advised to always make sure that you close CC before patching by going Menu > File > Quit 
Creative Cloud  to close it fully. However, if you did leave CC open when you use GenP, it will
automatically close CC for you.

Open GenP.v3.5.0-CGP  folder and run GenP 3.5.0.exe .

Go to Options tab and make sure "Always search for ACC" is checked, if it is not then check the box and
click on "Save Options".

For the other two Options, you can leave them as they are: Enable MD5 Checksum (Checked), Search
for files only in Adobe/Acrobat folders (Checked).

Go back to Main tab and click on "Search" and wait for it to return the results.

Check the three files for ACC at the top.+

+ At a later date when you just want to repatch CC after updating it, you can uncheck all other files using
"De/Select" and only check the three files for ACC at the top.

Click on "Patch" and let it run and finish.

The patch runs automatically and performs all the necessary actions (Do not touch anything until done).
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You will know it’s finished when it switches to the Log tab (this is only informational; continue with the
guide).

💁‍♂️ Every time CC gets updated, you must repatch it with GenP again.

⚠️ Possible Problem & Solution - Step 3

⚠️ If you're having issues opening GenP, ensure you've followed step 2 and either whitelisted it or fully
disabled your used antivirus.

⚠️ Required files for patching are not shown after using Search; only Creative Cloud is listed:

Either click on the "[Click to expand/collapse all]" banner at the top, click on the "v" on the right, or
double-click the Creative Cloud title bar.

⚠️ Fails to find CC or it takes a long time to search:

You can manually use "Path" to select Adobe Creative Cloud  in C:\Program Files\Adobe , so the
path shown in GenP is now set to C:\Program Files\Adobe\Adobe Creative Cloud , after which
you do "Search" and "Patch" as mentioned above.

⚠️ Fails to find CC files needed for patching:

In rare cases, GenP fails to find your CC installation automatically and opens up a new File Explorer
window requesting you locate the required files to patch individually.

If this happens, you’ll have to select the files manually; they are located in these directories:

C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\AppsPanel

C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\ADS

C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\HDBox

 

4. Open Creative Cloud > Apps > Install
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You are advised to run CC as Administrator

Go to CC location: C:\Program Files\Adobe\Adobe Creative Cloud\ACC .

Find Creative Cloud.exe , right-click on it, and select Properties > Compatibility .

Check the box for "Run this program as an administrator", then Apply > OK .

On the side menu, if you click on "Apps"

You should now have the install button. Install all the apps you want, wait until everything is installed.

DON’T OPEN ANY YET.

Once everything you want is installed, go to Menu > File > Quit Creative Cloud

If this AGS popup is ever shown whilst CC is open - do NOT install AGS (Adobe Genuine Service), - check
the box for "Don’t show again" and choose "Decline".
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⚠️ Possible Problem & Solution - Step 4

⚠️ Running CC as Administrator and getting UAC prompt at startup:

Upon starting your device, you might get a User Account Control (UAC) prompt asking if you want to
allow Adobe Creative Cloud to make changes to your device, you just click on "Yes" and carry on as
normal.

If you have toggled off "Launch Creative Cloud at login" as described in step one, the UAC prompt
should only appear when you manually open the CC app, otherwise, it will appear at login.
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This UAC prompt is shown to check that you allow Adobe to run CC as Administrator, so when CC is
used it has the correct level of Administrator privileges to be able to install or update either CC or any
individual app properly and make the necessary changes and additions to your own system.

The UAC prompt refers to CC being run as Administrator, as setup in this step already, with the apps
location here: C:\Program Files\Adobe\Adobe Creative Cloud\ACC\Creative Cloud.exe .

⚠️ UAC prompt still shows at startup even with "Launch Creative Cloud at login" toggled off:

Please be aware that preventing CC from opening at login will not prevent the background processes
used for Adobe apps and services from starting. These background processes will still open regardless
of whether CC opens during the login process.

Therefore, for some users, the UAC prompt will still appear, not for CC itself, but for the CC background
processes that are still running at startup.

⚠️ Removing UAC prompt at startup:

Disable via Task Manager - This will disable CC from running at startup, which means the UAC prompt
will only be shown when you manually open CC yourself.

Open Task Manager and go to the Startup tab, locate Creative Cloud.exe , right-click on it, and select
"Disable".

You will need to restart your used device for this change to take effect.
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5. Run GenP on the installed apps

Note that you should be running GenP as Administrator.

Open GenP.v3.5.0-CGP  folder and run GenP 3.5.0.exe .

Go to Options tab and check that "Always search for ACC" is unchecked, if it is not then uncheck the box
and click on "Save Options".

For the other two Options, you can leave them as they are: Enable MD5 Checksum (Checked), Search
for files only in Adobe/Acrobat folders (Checked).

Go back to Main tab and click on "Search" and wait for it to return the results. (it will look at the default
locations in C: ) - (The "Path" is if apps were installed somewhere else; most will never need to use this
option).

You can de-select the respective paths if you have any programs you don’t want to patch.

Finally, click on "Patch" to run the patch on the apps and wait until it’s done.

💁‍♂️ Every time the apps get updated, you must repatch the respective apps again with GenP.

⚠️ Possible Problem & Solution - Step 5

⚠️ If you're having issues opening GenP, ensure you've followed step 2 and either whitelisted it or fully
disabled your used antivirus.

⚠️ Required files for patching are not shown after using Search; only the installed apps are listed:

Either click on the "[Click to expand/collapse all]" banner at the top, or for a specific app, click on the "v"
on the right, or double-click the app's title bar.

⚠️ Fails to find any apps or takes a long time to search:

You can manually use "Path" to select Adobe  in C:\Program Files , so the path shown in GenP is
now set to C:\Program Files\Adobe , or if installed elsewhere you need to set the folder location to
where you have installed the apps instead, after which you do "Search" and "Patch" as mentioned
above.
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⚠️ Patching UWP apps:

Support for Fresco/XD has been dropped and discontinued in all subsequent versions of GenP.

Fresco is now free across all tiers, eliminating the need for patching. A patched version provides no
additional benefits over the free one.

XD entered "maintenance mode" in 2023 after Adobe halted active development. Since then, updates
have been limited to minor bug fixes and workflow improvements, including the release of XD v58 in
February 2025.

For those who still wish to patch UWP apps (Fresco/XD), GenP v3.4.2, available only in the Download
Directory, must be used, as it was the final version to support these apps.

⚠️ Fails to find UWP apps (GenP v3.4.2 Only):

Make sure you have clicked on "Runas TI", otherwise you can manually use "Path" to select
WindowsApps  in C:\Program Files , so the path shown in GenP is now set to C:\Program 
Files\WindowsApps , after which you do "Search" and "Patch" as mentioned above.

 

6. OPEN THE APPS THROUGH THEIR .EXE  and NOT FROM Creative Cloud directly;

Be aware that you are free to pin apps and open them from the taskbar, start, .exe, shortcut, etc.

The important part is: Don’t open CC just to click OPEN on Photoshop, for example.

⚠️ Possible Problem & Solution - Step 6

⚠️ When you open an app, you receive an error message stating that Windows cannot access the
specified file:

Your used antivirus may scan new apps upon opening and mistakenly flag them as malicious as they
have been patched by GenP.

To resolve this, you'll need to access your used antivirus quarantine and restore the required .exe
involved. Add an exclusion for the specific app to prevent it from being removed again in the future.

Everything should be working now! End of Guide.

 

⚠️ Installing/Updating - Possible Problem & Solution

Always check the regularly updated Compatibility List before updating any apps, otherwise don't
update.
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APPS: If you want to install more apps / update them, hit "Install/Update" on said app, let it
download, and then run GenP on them again, using "Search" and "Patch".

 

CC: If you update CC, hit "Update", let it update, and then run GenP on it again, using "Search" and
"Patch".

 

GENP: To update GenP, simply download the latest version from any of the available download links
and use it for any future patching.

 

Run GenP on compatibility mode with Windows 10/11 if any other issues occur.

If something isn't working properly for you or you get pop-ups appearing, you should check the
TROUBLESHOOT SECTION towards the bottom of the guides page.

 

 

☢️ Guide #4 - NOTHING IS WORKING / FULL CLEANING
Video Tutorial (0 to 7:20 only)

DOWNLOADS / TOOLS NEEDED

🔗 Adobe Creative Cloud Cleaner Tool

Another option (but not covered below)

🔗 Revo Uninstaller (Optional)

 

⚠️ Attention - please read

If you continue to have issues overall or simply want to restore normalcy, we advise removing everything
Adobe-related and starting fresh.

Brushes, patterns, plugins, or other assets should be saved/exported to folders outside Adobe’s main
folders.
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Referring to master files where all edits are done, such as .psd , .ai , .ae , etc...

Export and save them into a dedicated folder if you don’t have it.

 

Instructions to Fully Clean:

1. Remove any trace of ALL Adobe

Run Adobe Cleaner Tool in ALL | (E, Y, 1, Clean All, Y).

Check Windows Control Panel > Uninstall and see if the app was successfully removed; otherwise,
remove it manually.

 

2. Delete Adobe folders from your disk drive

C:\Program Files

C:\Program Files\Common Files

C:\Program Files (x86)

C:\Program Files (x86)\Common Files

%appdata%  to go to AppData\Roaming

%localappdata%  to go to AppData\Local

%localappdata%/temp  or just %temp%  to go to AppData\Local\Temp

 

CoreSync Removal Issue

Some users might not be able to delete CoreSync_x64.dll as it says that it is still in use, it is a common
leftover from the CC app uninstall.

To remove this, you need to go to your CoreSync folder C:\Program Files (x86)\Common 
Files\Adobe  and rename the folder from CoreSyncExtension  to CoreSyncExtension.old

Or you can go to the file itself C:\Program Files (x86)\Common Files\Adobe\CoreSyncExtension
and rename the file from CoreSync_x64.dll  to CoreSync_x64.dll.old .

Go to Task Manager and find Windows Explorer, right-click on it and choose restart (or just restart your
computer), then you are able to delete the folder.
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3. Registry Editor

Windows key, write "registry editor" and it should show up.

On HKEY_CURRENT_USER  and HKEY_LOCAL_MACHINE

Look for Software and delete Adobe.

 

4. Remove Windows Firewall rules, Hosts file lines, or Scheduled Tasks

For Windows Firewall

Go to Windows > Windows Firewall > Advanced Settings

Check in both Outbound and Inbound

Remove or disable any rules blocking Adobe processes or services.

You must do the same if you created these in your own used firewall.

 

For Hosts File

Open Notepad (as admin), go to FILE > OPEN > C:\Windows\System32\drivers\etc

Remove all the lines related to "ADOBE" from there, replace with the default hosts lines from below,
save the file and reboot your system.

Note, that when saving your hosts file from Notepad you need to change the Save as type to All file 
types (*.*)  and NOT Text files (*.txt)  or Notepad will always try to tack on a .txt
extension.

If you get told that you don't have permission to save the hosts file back into your etc folder as you didn't
follow the steps and open Notepad (as Admin), you will have to save it to your desktop instead.

There you should check it has been saved as file  and NOT .txt  by going to your Explorer window
and View > Show > File Name Extensions . Check your hosts file name, if it says hosts.txt  you
need to remove the .txt  and agree to the changes. You then cut and paste it back into your etc folder,
saying yes to replace your existing hosts file.

 

DEFAULT HOSTS LINES - You can copy-and-paste it
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# Copyright (c) 1993-2009 Microsoft Corp.

#

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

#

# This file contains the mappings of IP addresses to host names. Each

# entry should be kept on an individual line. The IP address should

# be placed in the first column, followed by the corresponding host name.

# The IP address and the host name should be separated by at least one

# space.

#

# Additionally, comments (such as these) may be inserted on individual

# lines or following the machine name denoted by a ‘#’ symbol.

#

# For example:

#

#      102.54.94.97     rhino.acme.com          # source server

#      38.25.63.10      x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.

#      127.0.0.1        localhost

#      ::1              localhost

 

For Scheduled Tasks

Open Task Scheduler, locate the UpdateHostsFile  task, right-click it, and select "Delete" to remove it.

If you used the Advanced Method with the GenP command line flag, perform this additional step:

Go to C:\Windows\System32\drivers\etc  and delete the two files named UpdateHostsFile.ps1
and UpdateHostsFile.log .

 

5. Restart the PC

Adobe should not be on your system; if you install it again, it should behave normally 🙂

 

 

🐒 Guide #7 - Monkrus Individual / Collection (Easiest
Method)
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Video Tutorial: Monkrus Individual / Collection Install

- Thanks throwaway4rule34

DOWNLOAD NEEDED

🔗 Torrent Software - qBittorrent

ADDITIONAL DOWNLOAD OPTIONS (most recent sorted by release-date)

🔗 Monkrus Individual - Acrobat PRO (get only x64 versions only)

🔗 Monkrus Individual - After Effects

🔗 Monkrus Individual - Animate (PRO version doesn't work)

🔗 Monkrus Individual - Audition

🔗 Monkrus Individual - Character Animator (PRO version doesn't work)

🔗 Monkrus Individual - Illustrator

🔗 Monkrus Individual - InDesign

🔗 Monkrus Individual - Lightroom Classic

🔗 Monkrus Individual - Media Encoder (Must match same version of Premiere / After Effects to
properly work)

🔗 Monkrus Individual - Photoshop

🔗 Monkrus Individual - Premiere Pro

🔗 Monkrus Individual - Speech to Text Add-on for Premiere (Must be compatible with same version
of Premiere, check the description in the tracker for compatibility with Premiere versions)

🔗 Monkrus Individual - Substance

🔗 Monkrus Individual - XD

🔗 Monkrus Collection (All Apps)

 

A few details to pay attention to

⚠️ DO NOT RUN GenP ON MONKRUS - If switching completely from CC+GenP to Monkrus, please
run GUIDE 4 to clean everything. You want a clean slate to avoid problems.

⛔ Generative Fill, FireFly, or any other AI features DO NOT WORK anymore - stop asking about it
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Without a valid subscription or active trial (7 days), you can forget about it. It’s been adapted into the
monthly credits service for valid subscription users (pay-wall). Therefore, it’s gone.

 

Instructions to install Monkrus Individual / Collection:

1. Download and Install the Torrent Software - qBittorrent

 

2. Choose the app of choice from Monkrus Individual or all apps in Collection

⚠️ Antivirus may have blacklisted the site causing it to not "load / could not reach URL"; if you disable
your used antivirus, it should load normally.

To translate the page to your language, on the top-right, it says, "Translate" with flag icons.

Go down until you find "DOWNLOAD FROM A TORRENT TRACKER OF YOUR CHOICE".

We recommend that you use either UnionDHT or PB.WTF as neither of them requires you to register or
sign up to any service to be able to download any Monkrus torrent.

 

On PB.WTF:
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Does not require any registration.

Click on "Скачать торрент" ("Download torrent") highlighted with the red arrow and frame, in the next
window above the captcha box, it will be counting down 10 secs saying 'Download torrent - Searching for
file to download: 10 seconds'.

Wait for the countdown to complete, tick the captcha box and you can click on download to get the small
magnet link downloaded, then you can open it in your own torrent software.

Otherwise, click on "Magnet ссылка" ("Magnet link") highlighted with the the blue arrow and frame, to
have your web browser prompt you about opening it as below.

 

On UnionDHT:

Does not require any registration.

Click on "Скачать .torrent" ("Download torrent") highlighted with the red arrow, to get the small magnet
link downloaded, then you can open it in your own torrent software.

Otherwise, click on the "Magnet Icon" itself highlighted with the the blue arrow, to have your web browser
prompt you about opening it as below.

 

Once you click on the "Magnet Icon", you should get these prompts or similar, which you’ll want to allow,
then choose "qBit" to open the link.
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Now you should choose where you want the files to be downloaded to, make sure everything of the files
is selected and click "OK" to start.
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Let it download. (when it reaches 100%, it changes from "Downloading" to "Seeding"; the files have been
downloaded, you can simply right-click it and press remove).
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3. Go to the downloaded folder, find the "disk or .iso file", double-click to open and run "autoplay.exe"
as ADMINISTRATOR.

For individual: Proceed with the install setup.

For collection: Select the apps you want to install (you don’t need all).

⚠️ Attention - Majority apps should work without any account signed in (cloud-based might need)

 

If the install window doesn’t show up or Errors (failed to...)

Turn your used antivirus OFF for the installation process. That may be preventing the window from
showing up (it may be Windows Defender or another AV you have). You can turn it back on after the
install.
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4. Once everything is installed and working correctly, you can EJECT the DVD drive found at
"MyComputer / This PC"

The drive is created when you open the ".iso" file, which is, in fact, a virtual installation CD; it has no
other purpose.

You may also delete or not delete the files extracted from the torrent (installer). It’s up to you whether
you want to keep them.

 

🪙 To update Monkrus, just install the newer version on top of the old one

If something isn't working properly for you or you get pop-ups appearing, first check Monkrus own
FAQ Section which is found on the torrent tracker (where you obtained the magnet link for the app itself
as already mentioned in step 2 of this Monkrus Guide).

Most issues with Monkrus versions are already covered in the FAQ Section, it should always be read first
otherwise you could end up just being directed back there to read it yourself to fix your issue.

Otherwise, you can check the TROUBLESHOOT SECTION towards the bottom of the guides page,
although note that not all methods given there will work for Monkrus.

 

 

► Guide #8 - Blocking unnecessary Adobe Background
processes(PS/DC)
Do not block any other background processes apart from the ones mentioned here, blocking other
background processes is not advisable or required.

- Thanks u/Verix-

For Photoshop

All you have to do is rename these four exe-files.

1. C:\Program Files (x86)\Adobe\Adobe Sync\CoreSync\CoreSync.exe

2. C:\Program Files\Adobe\Adobe Creative Cloud Experience\CCXProcess.exe

3. C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop Common\ADS\Adobe Desktop 
Service.exe

4. C:\Program Files\Common Files\Adobe\Creative Cloud Libraries\CCLibrary.exe
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--> Just add .bak  after the .exe .

For example: CoreSync.exe  --> CoreSync.exe.bak

(If you don’t see .exe  in the file name, you need to make the file name extensions visible in your explorer).

For Acrobat DC

All you have to do is rename these exe-files.

1. C:\Program Files\Adobe\Acrobat DC\Acrobat\AdobeCollabSync.exe

--> Just add .bak  after the .exe .

For example: AdobeCollabSync.exe  --> AdobeCollabSync.exe.bak

(If you don’t see .exe  in the file name, you need to make the file name extensions visible in your explorer).

FOR UPDATES ON ALL:

To update Creative Cloud, it’s recommended to revert at least the name change of C:\Program Files 
(x86)\Common Files\Adobe\Adobe Desktop Common\ADS\Adobe Desktop Service.exe .

To update the other apps, you should undo all changes to be on the safe side.

 

 

► Guide #9 - Fix Neural filters not available in Photoshop
This method applies to GenP users only, Monkrus users should check and use the method mentioned in
the FAQ Section instead.

Thanks u/Verix-, from GenP Discord.

1. Navigate to C:\Users\"YourUsername"\AppData\Roaming\Adobe\UXP\  or hit Win+R and type in
%appdata% .

2. Delete the folder PluginsStorage .

3. Restart Photoshop and run it as administrator.

4. Download the neural filters you need.

 

If the button is greyed out, go on.

1. Close Photoshop and Creative Cloud if they are open.
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2. Open Task Manager and ensure that no Adobe-related processes are running in the background. If there
are, end those processes.

3. Open Creative Cloud and log out of your account.

4. Close Creative Cloud and ensure it is no longer running in the background.

5. Open Creative Cloud again and log in to your account.

6. Close Creative Cloud and ensure it is no longer running in the background.

7. Open Photoshop and check if the Neural Filters option is available. If it is not, try loading an image and
checking again.

 

 

(...) TROUBLESHOOT SECTION
 

Before doing anything, make sure you are using the correct method to fix the appropriate popup.

Do not use a virtual IP address from a VPN or Proxy, as it will circumvent local settings such as the
hosts file or firewall rules.

If using a firewall, ensure it is enabled, or any rules set up through Windows Defender or third-party
programs will not be applied.

 

UNLICENSED POPUPS / ACCEPT TERMS POPUP

Both of these popups are fixed using the same method, follow the instructions provided after the sample
images.

UNLICENSED POPUPS
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ACCEPT TERMS POPUP
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These popups are fixed by adding the latest lines to your hosts file, and where necessary as the popup
is still showing in your app, blocking the apps own .exe in your used firewall.

You can make use of the Pop-up Blocker button on GenP to automate the process of updating your
hosts file.

Before using Pop-up Blocker button your hosts file needs to be cleared of any existing Adobe
related lines to avoid any issues, you also need to remove any existing GenP-related firewall rule
for Adobe too - if you have 'Adobe Unlicensed Pop-up rule' remove it.

The Pop-up Blocker button should only be used as a one-off fix. If you have already used it and just want
to update your hosts file with the latest lines, you should use the auto-update method with the GenP
command line flag, scroll down to 'HOSTS FILE AUTO-UPDATE SETUP USING GENP COMMAND
LINE FLAG' and follow the instructions. Alternatively, you can use the manual method instead and if you
are not confident in doing this yourself, go to the Pop-up Tools tab and click on 'Edit Hosts' to open your
hosts file, then scroll down to 'HOSTS FILE / FIREWALL RULE MANUAL SETUP' and follow the
instructions for Option 1. You can also use third-party apps such as SwitchHosts or HostsMan to
automate the update process.

For further information about using Pop-Up Blocker or to change the used hosts list URL, scroll down to
"POP-UP BLOCKER BUTTON ON GENP" and follow the instructions from there.

The Pop-up Blocker button is not a guaranteed automated solution that works for everyone all
the time. There will be instances when it doesn't function properly, and in such cases, using the
manual method will be the only available fix.

 

ADOBE GENUINE SERVICE (ALERT) POPUP
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Note that this popup is very similar to the unlicensed popup, however it is distinguished by this
popup having "Adobe Genuine Service Alert" at the top of the popup window.

This popup is fixed by making use of the "Remove AGS" button found in the Pop-up Tools tab.

If it is still appearing after using the "Remove AGS" button, then make use of one of the old fallback
methods listed below.

➜ Uninstall AGS (Manual Method) - Adobe Genuine Service and removal of AdobeGCClient folder

Open Windows Settings > Apps > Installed Apps , find Adobe Genuine Service and uninstall it.

Go to C:\Program Files (x86)\Common Files\Adobe  and delete AdobeGCClient  folder.

➜ Uninstall AGS (Automated Method) - Adobe Genuine Service

Open PowerShell as Admin and enter:

[System.Diagnostics.Process]::Start("C:\Program Files (x86)\Common 

Files\Adobe\AdobeGCClient\AdobeCleanUpUtility.exe")

Follow the on-screen instructions.

If that directory is absent, then the service won’t be installed.

➜ Block AGS via Firewall

Create Outbound rules on Adobe Genuine Service

Path of AGS:
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C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop 

Common\AdobeGenuineClient\AGSService.exe

C:\Program Files\Adobe\Acrobat DC\Acrobat\GC\AGSService.exe

⚠️ If the issue persists, you can create the same rules for "Inbound"

The Remove AGS button is not a guaranteed automated solution that works for everyone all the
time. There will be instances when it doesn't function properly, and in such cases, using one of
the three old fallback methods will be the only fix available to you.

 

SORRY, THIS APP IS UNAVAILABLE POPUP

This popup is fixed by adding the latest lines to your hosts file.

 

CAN’T VERIFY YOUR SUBSCRIPTION POPUP
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This popup is fixed by doing one of three things as listed here:

Have you patched both the CC app and your individual apps with GenP when installed?

Or, have you repatched both the CC app and your individual apps with GenP after any updates?

If all done, then move on...

Have you added latest lines to the hosts file and possibly blocked the app in your used firewall?

If all done, then move on...

Did you verify your Adobe account through the email verification from Adobe when you first created your
Adobe account?

If no, do this...

You needed to have verified your used email address with Adobe when you first created your Adobe
account.

If you used a temporary email, you needed to have the temporary email inbox open long enough to
receive the email verification from Adobe, which you then opened to verify your account.

If you used a temporary email, you will need to create a new Adobe account, this time actually verifying
your used email.

If you have used an existing email that you still have access to the inbox, you can sign into your free
Adobe account online and get them to resend you the verification email from there.

Once you have your new or existing account all verified...
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Close all apps and sign out of your CC app, sign back into your CC app with your now verified Adobe
account.

After signing back in you always need to repatch your CC app with GenP and then repatch all your
individual apps with GenP.

 

VERIFY YOUR IDENTITY WITH CODE POPUP
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This popup is fixed by doing one of two things as listed here:

You needed to have verified your used email address with Adobe when you first created your Adobe
account.
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If you have used an existing email that you still have access to the inbox, you can sign into your free
Adobe account online and get them to resend you the verification email from there.

You won’t be able to use the same six figure code on the original email as it is time sensitive due to
security measures, you will always need to have a new code sent out to you.

If you do not have access to used email inbox anymore, do this...

If you used a temporary email, you needed to have the temporary email inbox open long enough to
receive the email verification from Adobe, which you then opened to verify your account.

If you used a temporary email, you will need to create a new Adobe account, this time actually verifying
your used email.

Once you have your new or existing account all verified...

Close all apps and sign out of your CC app, sign back into your CC app with your now verified Adobe
account.

After signing back in you always need to repatch your CC app with GenP and then repatch all your
individual apps with GenP.

 

FREE TRIAL POPUP

This popup is fixed by doing one of five things as listed here:

Have you patched both the CC app and your individual apps with GenP when installed?

Or, have you repatched both the CC app and your individual apps with GenP after any updates?
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If all done, then move on...

Have you added latest lines to the hosts file and blocked the app in your used firewall?

If all done, then move on...

Create a new verified Adobe account, close all apps and sign out of your CC app, sign back into your CC
app with your new Adobe account.

After signing back in you always need to repatch your CC app with GenP and then repatch all your
individual apps with GenP.

If all done, then move on...

Can you click on the 'x' on the top-right of the popup to close the free trial popup and restart the app?

If no, do this...

Accept the free trial and carry on using it as normal, it won't affect anything within your app.

As you have the latest lines in your hosts file and the app blocked in your used firewall, it will not be able
to access the internet and check license status.

 

TRIAL BANNER (TOP-RIGHT OF APP WINDOW)

This is normally removed when patching with GenP, however on some new installs or updates it doesn’t
and is still being shown for a small minority of users.

For those who have it appearing for them you do not need to worry, it does not affect the performance of
the app in any way at all and is purely cosmetic in appearance.

As long as you have done the correct procedure of patching both CC app and individual apps with GenP,
added lines in hosts file and, if required, blocked in used firewall, it will be non-functional and can be
ignored.
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We take no responsibility if you try to remove it yourself and anything goes wrong as that is all on you,
especially if you are just pedantic or using non-genuine versions for commercial use and you can't have
it showing as 'x' trial days left / Trial ended / Subscription suspended.

 

ADOBE ACROBAT PRO EXCEPTION

Adobe Acrobat Pro only needs the latest lines in your hosts file for it to work, although if you still feel the
need to block it in your used firewall, you block these files.

Acrobat.exe - C:\Program Files\Adobe\Acrobat DC\Acrobat

AcroCEF.exe - C:\Program Files\Adobe\Acrobat DC\Acrobat\AcroCEF

AcroCEF.exe - C:\Program Files\Adobe\Acrobat DC\Acrobat\acrocef_1

 

All the following options are to help avoid either Credit Card / Unlicensed or Disabled / Accept Terms / Free Trial
/ Verify your subscription / Sorry, this app is unavailable pop-ups.

 

POP-UP BLOCKER BUTTON ON GENP

For those who want an automated option to block most popups, you can make use of the Pop-up Blocker button
on GenP and this will update your hosts file with the latest lines for you.

If you are wanting GenP to use an alternative hosts list URL instead of the used default URL, go to the
Options tab and change the URL field from the default to your own preferred choice, click on "Save
Options" to save your change.

Make a mistake or just want to revert back to the default URL, simply clear the URL field and click on
"Save Options", the hosts file URL will be reset back to default again and you will get an "Empty URL"
popup appear informing you about it, click on "OK" to close the popup.

The Pop-up Blocker button should only be used as a one-off fix method, rather than kept being applied every
time you want to just update your own hosts lines, there is a rare chance that if you use it multiple times over
that your hosts file could be wiped clean instead of being updated.

To keep your hosts file updated with the latest release, you have three options: use the auto-update method
with the GenP command line flag, scroll down to 'HOSTS FILE AUTO-UPDATE SETUP USING GENP
COMMAND LINE FLAG' and follow the instructions. Alternatively, you can use the manual method and if you're
not confident in doing this yourself, go to the Pop-up Tools tab and click on 'Edit Hosts' to open your hosts file,
then scroll down to 'HOSTS FILE / FIREWALL RULE MANUAL SETUP' and follow the instructions for Option 1.
You can also use third-party apps such as SwitchHosts or HostsMan to automate the update process.

Log InSkip to main content

4/1/25, 11:13 AM GenP

https://www.reddit.com/r/GenP/wiki/redditgenpguides/?rdt=46251 39/52

https://www.reddit.com/
https://www.reddit.com/login/


Before using Pop-up Blocker button your hosts file needs to be cleared of any existing Adobe related
lines to avoid any issues, you also need to remove any existing GenP-related firewall rule for Adobe too
- if you have 'Adobe Unlicensed Pop-up rule' remove it.

To edit your hosts file either manually open it yourself with Notepad (as Admin), or go to the Pop-up
Tools tab and click on "Edit Hosts" to open your hosts file.

The GenP "Edit Hosts" method will make a backup of your existing hosts file before opening it, so if you
make any errors and need to go back, then you can just click on "Restore Hosts" to revert back to the
saved copy instead.

The "Restore Hosts" button will be greyed out and only become available if you edited your hosts file
through GenP.

The "Clean Hosts" button will only work for those who have edited their hosts file through GenP.

To edit your Windows Firewall, you can either manually open it yourself, or you can make use of the
Manage Windows Firewall option in the Pop-up Tools tab, click on "Open Windows Firewall" to open
Windows Firewall.

If you have done all of the above steps and still have issues with Pop-up Blocker button after using
"Edit Hosts" option on GenP, then it is recommended to use the manual method instead and to repeat
the same steps of editing your own hosts file yourself.

The Pop-up Blocker button is not a guaranteed automated solution that works for everyone all the time.
There will be instances when it doesn't function properly, and in such cases, using the manual method
will be the only available fix.

 

HOSTS FILE AUTO-UPDATE SETUP USING GENP
COMMAND LINE FLAG
This can only be used with GenP method.

Do not use a virtual IP address from a VPN or Proxy, as it will circumvent local settings such as the
hosts file or firewall rules.

Create a scheduled task that uses the command line flag AdobeGenP.exe -popup  to auto-update the hosts
file daily at a set time, whether you are logged in or not.

If the scheduled task is missed because your device is off, the task is configured to run as soon as possible
after the missed scheduled start.

Before running the scheduled task for the first time, you will need to clean your hosts file and remove
all existing Adobe-related lines.
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If you use your hosts file for additional lines unrelated to Adobe, it is recommended to ensure that your hosts file
is saved with an empty blank line at the end so that the latest lines can be placed on a new line at the end.

To edit your hosts file, open Notepad (as Admin), go to FILE > OPEN > 
C:\Windows\System32\drivers\etc  <- Copy and paste this directory to the file explorer bar, press enter and
select the file "hosts".

⚠️ (If you do not see it, make sure you’re looking for All file types (*.*)  and NOT Text files 
(*.txt) )

Note, that when saving your hosts file from Notepad you need to change the Save as type to All file 
types (*.*)  and NOT Text files (*.txt)  or Notepad will always try to tack on a .txt
extension.

If you get told that you don't have permission to save the hosts file back into your etc folder as you didn't
follow the steps and open Notepad (as Admin), you will have to save it to your desktop instead.

There you should check it has been saved as file  and NOT .txt  by going to your Explorer window
and View > Show > File Name Extensions . Check your hosts file name, if it says hosts.txt  you
need to remove the .txt  and agree to the changes. You then cut and paste it back into your etc folder,
saying yes to replace your existing hosts file.

 

(...) CREATING THE SCHEDULED TASK
You have a choice between two methods for the scheduled task: Basic and Advanced.

Basic Method: Updates the hosts file with the latest lines.

Advanced Method: Creates a backup of the existing hosts file, adds the latest lines, verifies the
changes, reverts to the backup if necessary, and updates the log file with the required entries.

 

BASIC METHOD - SCHEDULED TASK ONLY:

To set a scheduled task to update the hosts file using PowerShell, follow these steps:

Make sure to replace C:\GenP.v3.5.0-CGP\GenP 3.5.0.exe  with the path to your own GenP 3.5.0.exe
file before running.

1. Use the following command in PowerShell (as Admin) to create the scheduled task:

$action = New-ScheduledTaskAction -Execute "C:\GenP.v3.5.0-CGP\GenP 3.5.0.exe" -

Argument "-popup"

$trigger = New-ScheduledTaskTrigger -Daily -At "00:00AM"

$settings = New-ScheduledTaskSettingsSet -AllowStartIfOnBatteries -
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DontStopIfGoingOnBatteries -StartWhenAvailable -MultipleInstances IgnoreNew -

ExecutionTimeLimit (New-TimeSpan -Minutes 1)

Register-ScheduledTask -TaskName "UpdateHostsFile" -Action $action -Trigger $trigger 

-Settings $settings -User "SYSTEM" -RunLevel Highest

$task = Get-ScheduledTask -TaskName "UpdateHostsFile"

$task.Settings.WakeToRun = $false

Set-ScheduledTask -TaskName "UpdateHostsFile" -Settings $task.Settings

Start-Process -FilePath "SCHTASKS" -ArgumentList "/End /TN UpdateHostsFile" -

NoNewWindow -Wait

exit

2. If done correctly, it will look like this after running the command:

3. This command will create a scheduled task named UpdateHostsFile  in Task Scheduler.

4. The UpdateHostsFile  task is now set up and in "Ready" status, waiting for the scheduled time to
run.

5. To test it immediately, open Task Scheduler, right-click on the UpdateHostsFile  task, and select
"Run."

Note: If you have Task Scheduler open while running the PowerShell script, you may need to close and reopen
it to see the newly created task.

First Use:

It will change your existing hosts file to hosts.bak, creating a backup of your existing hosts file, it is your
choice whether to keep or delete it.

Ongoing Use:

Your hosts file will be updated daily, with all the latest entries contained between two commented lines,
like this:

# START - Adobe Blocklist

(Latest lines contained within here)
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# END - Adobe Blocklist

Run Task On Demand:

You can manually run the UpdateHostsFile  task in Task Scheduler at any time to update the lines if
they've changed during the day.

 

ADVANCED METHOD - SCHEDULED TASK, BACKUP ON EVERY RUN, VERIFICATION, REVERT TO
BACKUP ON FAILURE, AND LOGGING:

To set up a scheduled task that creates a backup before each update, verifies the changes, restores the saved
backup in case of failure, and generates a log file, follow these steps:

Make sure to replace C:\GenP.v3.5.0-CGP\GenP 3.5.0.exe  with the path to your own GenP 3.5.0.exe
file before running.

1. Use the following command in PowerShell (as Admin) to create the required PS1 file:

$scriptDir = "C:\Windows\System32\drivers\etc"

$scriptPath = "$scriptDir\UpdateHostsFile.ps1"

if (-not (Test-Path -Path $scriptDir)) {

New-Item -ItemType Directory -Path $scriptDir -Force

}

Set-Content -Path $scriptPath -Value @'

$logDirectory = "C:\Windows\System32\drivers\etc"; $logFile = 

"$logDirectory\UpdateHostsFile.log";

if (-not (Test-Path -Path $logDirectory)) { New-Item -ItemType Directory -Path 

$logDirectory -Force };

Set-Content -Path $logFile -Value ""; function Write-Log {

param ([string]$message); $timestamp = Get-Date -Format "yyyy-MM-dd HH:mm:ss"; 

$logEntry = "$timestamp - $message";

Add-Content -Path $logFile -Value $logEntry;

};

Write-Log "Script execution started."; $hostsFile = 

"C:\Windows\System32\drivers\etc\hosts";

$backupFile = "C:\Windows\System32\drivers\etc\hosts.bak";

if (Test-Path $hostsFile) {

Copy-Item -Path $hostsFile -Destination $backupFile -Force;

Write-Log "Backup of hosts file created as hosts.bak.";

} else {

Write-Log "Hosts file not found. Cannot create backup.";

}

Write-Log "Executing GenP.exe with arguments: -popup";

Start-Process -FilePath "C:\GenP.v3.5.0-CGP\GenP 3.5.0.exe" -ArgumentList "-popup" -

NoNewWindow -Wait;
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Write-Log "Finished executing GenP.exe.";

Start-Sleep -Seconds 5; Write-Log "Hosts file validation initiated.";

if (Test-Path $hostsFile) {

$originalContent = Get-Content $backupFile;

$newContent = Get-Content $hostsFile;

Write-Log "Checking for expected entries in the hosts file.";

$expectedPattern = "0\.0\.0\.0";

if ($newContent -match $expectedPattern) {

Write-Log "Validation passed: Hosts file contains the expected entries.";

} else {

Write-Log "Validation failed: Expected pattern '$expectedPattern' not found in the 

hosts file.";

Copy-Item -Path $backupFile -Destination $hostsFile -Force;

Write-Log "Restored the hosts file from backup due to validation failure.";

}

} else {

Write-Log "Hosts file missing. Restoring from backup.";

Copy-Item -Path $backupFile -Destination $hostsFile -Force;

}

Write-Log "Script execution completed successfully.";

'@

if (Test-Path $scriptPath) {

Write-Output "Script file successfully created at $scriptPath."

} else {

Write-Output "Script file creation failed. Please check permissions or paths."

}

$action = New-ScheduledTaskAction -Execute "powershell.exe" -Argument "-NoProfile -

ExecutionPolicy Bypass -File $scriptPath"

$trigger = New-ScheduledTaskTrigger -Daily -At "00:00AM"

$settings = New-ScheduledTaskSettingsSet -AllowStartIfOnBatteries -

DontStopIfGoingOnBatteries -StartWhenAvailable -MultipleInstances IgnoreNew -

ExecutionTimeLimit (New-TimeSpan -Minutes 1)

try {

Register-ScheduledTask -TaskName "UpdateHostsFile" -Action $action -Trigger $trigger 

-Settings $settings -User "SYSTEM" -RunLevel Highest

} catch {}

try {

$task = Get-ScheduledTask -TaskName "UpdateHostsFile"

$task.Settings.WakeToRun = $false

Set-ScheduledTask -TaskName "UpdateHostsFile" -Settings $task.Settings

} catch {}

Start-Sleep -Seconds 5

try {

Start-ScheduledTask -TaskName "UpdateHostsFile"

} catch {}

exit
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2. If done correctly, it will look like this after running the command:

3. This command creates a scheduled task named UpdateHostsFile  in Task Scheduler. It also
generates two files called UpdateHostsFile.ps1  and UpdateHostsFile.log , both stored in your etc
folder alongside the hosts file for better organisation.

4. After creating the above files, it will automatically run the task, back up the existing hosts file, add the
latest lines, verify the changes, revert to the backup if necessary, and update the log file with the
required entries.

5. The UpdateHostsFile  task is now set up and in "Ready" status, waiting for the scheduled time to
run.

6. To test it immediately, open Task Scheduler, right-click on the UpdateHostsFile  task, and select
"Run."

Note: If you have Task Scheduler open while running the PowerShell script, you may need to close and reopen
it to see the newly created task.

First Use:
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It will create a backup of the existing hosts file, add the latest lines, verify the changes, revert to the
backup if necessary, and update the log file with the required entries.

Ongoing Use:

Your hosts file will be updated daily, with all the latest entries contained between two commented lines,
like this:

# START - Adobe Blocklist

(Latest lines contained within here)

# END - Adobe Blocklist

If any errors occur during the update, the task reverts to the saved backup.

The log file records all necessary entries and is overwritten on each run to conserve space rather than
maintaining a complete log history.

Run Task On Demand:

You can manually run the UpdateHostsFile  task in Task Scheduler at any time to update the lines if
they've changed during the day.

 

HOSTS FILE / FIREWALL RULE MANUAL SETUP
These can be used across GenP or Monkrus methods.

1️⃣ Option - PowerShell Cmd / Manual Hosts File Block;

2️⃣ Option - FIREWALL RULE on App-in-question.exe (disconnecting access to or from the internet);

3️⃣ Option - RESTORE (Reverse of options 1 and 2) (Fix CC not loading / loading continuously).

Do not use a virtual IP address from a VPN or Proxy, as it will circumvent local settings such as the
hosts file or firewall rules.

If using a firewall, ensure it is enabled, or any rules set up through Windows Defender or third-party
programs will not be applied.

 

❗ 𝗣𝗟𝗘𝗔𝗦𝗘 𝗥𝗘𝗔𝗗 𝗔𝗡𝗗 𝗦𝗧𝗢𝗣 𝗔𝗦𝗞𝗜𝗡𝗚 𝗜𝗧 𝗢𝗩𝗘𝗥 𝗔𝗡𝗗 𝗢𝗩𝗘𝗥 𝗔𝗚𝗔𝗜𝗡 ❗

⚠️ If your used antivirus is managing your Windows Firewall (it should say "firewall is being managed by third-
party" or something similar), then all the changes below must be applied in said antivirus firewall (that is on you
to figure out all of them have different menus and places; however, the paths to block are the same) - Also
whichever is "the boss" it must remain ON.
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If you are still getting pop-ups after following these steps, reread Guide 4 and try again. Otherwise, you’re out of
options.

 

(...) 1️⃣ HOSTS FILE BLOCK LIST (updated regularly)
1. Use the following command in PowerShell (as Admin) if your apps are warning you of unlicensed or
non-genuine usage:

Stop-Process -Name "Adobe Desktop Service" -force

⚠️ The hosts lines in the GenP "Pop-up" button option may not always be up-to-date (due to when a new line is
found). Therefore, always check to see if the lines added match the ones written in step 3 below. If some lines
are missing, either wait for the update or add them manually afterwards.

2. Open Notepad (as Admin), go to FILE > OPEN > C:\Windows\System32\drivers\etc  <- Copy and
paste this directory to the file explorer bar, press enter and select the file "hosts".

⚠️ (If you do not see it, make sure you’re looking for All file types (*.*)  and NOT Text files 
(*.txt) )

3. Copy the whole text block from (https://a.dove.isdumb.one/list.txt) and paste it into a blank line on
your hosts file. After that is done, save it.
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Note, that when saving your hosts file from Notepad you need to change the Save as type to All file 
types (*.*)  and NOT Text files (*.txt)  or Notepad will always try to tack on a .txt
extension.

If you get told that you don't have permission to save the hosts file back into your etc folder as you didn't
follow the steps and open Notepad (as Admin), you will have to save it to your desktop instead.

There you should check it has been saved as file  and NOT .txt  by going to your Explorer window
and View > Show > File Name Extensions . Check your hosts file name, if it says hosts.txt  you
need to remove the .txt  and agree to the changes. You then cut and paste it back into your etc folder,
saying yes to replace your existing hosts file.

Done.

 

Finding New IPs to Block Using Fiddler Classic:

You can learn how to find any new IPs to block using Fiddler Classic.

1. Download Fiddler Classic from its official site - Fiddler Download:

Choose "Personal Use" from the dropdown menu.

Enter a valid-looking email (e.g., adobe@fiddler.com). A temporary email is unnecessary.

Select any location for "Country/Territory."

Agree to the Fiddler End User License Agreement by checking the box.

Click "Download for Windows" to get the latest version.

2. Install and run Fiddler Classic to identify new IPs to block.

3. For additional guidance, watch the provided tutorial video - Fiddler Video

Reporting New IPs:

To report any new IPs not on the latest list, submit them here - Issues.

Do not post them on the GenP Subreddit as they will just get removed.

Check the same page periodically to see if others have contributed additional lines that haven't yet
been added to the list.

Note: We do not offer help or support for Fiddler Classic, as it is unrelated to GenP. Such posts will be
removed.

 

 

2️⃣
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(...) 2️⃣ FIREWALL RULE on App-in-question.exe
If the Hosts lines (updated and correctly applied) aren’t enough to stop it, you can experiment with the following:

Go to Windows Firewall > Advanced Settings

⚠️ If you see this warning, All firewall rules must be made in your antivirus firewall settings, and not on Windows
Defender Firewall (otherwise, they will have no effect) - But just in case, have in both.

Outbound Rules should be more than enough. Only do both if the first doesn’t work.

 

Create Outbound rule on each app with issues

Structure is the following:

File Type: Program

Program: You must select the actual "program" .exe inside the installed folder because the shortcut will
not work.

When looking for the program path, we want the Actual Program \ ".exe\" and not the shortcuts. How to distinct
them - LEFT: SHORTCUT \".EXE\" | RIGHT: ACTUAL \".EXE\"
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Typical path example would be: C:\Program Files\Adobe\Adobe Photoshop 
2025\Photoshop.exe  (Find the proper path for the app you need)

Action: Block Connection

Profile: All

Name: Name it whatever you want to know what’s blocking.

⚠️ If the issue persists, you can create the same rules for "Inbound"

 

You will lose internet access going out from the application, at the same time, the license also wont be able to
check if good or bad.

 

 

(...) 3️⃣ RESTORE (reverse of options 1 and 2)
It’s probably because of hosts file edits or firewall rules (including outdated ones) that either work against each
other or block something that shouldn’t be blocked.

Reverse Hosts File Edit:

1. Open Notepad (as Admin), go to FILE > OPEN > C:\Windows\System32\drivers\etc  <- Copy and
paste this directory to the file explorer bar, press enter and select the file "hosts".

⚠️ (If you do not see it, make sure you’re looking for All file types (*.*)  and NOT Text files 
(*.txt) )

 

2. Remove all lines related to Adobe stuff, save the file and reboot your system
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Remove all the lines related to "ADOBE" from there, replace with the default hosts lines from ☢️ Guide
#4 - NOTHING IS WORKING / FULL CLEANING, save the file and reboot your system.

Note, that when saving your hosts file from Notepad you need to change the Save as type to All file 
types (*.*)  and NOT Text files (*.txt)  or Notepad will always try to tack on a .txt
extension.

If you get told that you don't have permission to save the hosts file back into your etc folder as you didn't
follow the steps and open Notepad (as Admin), you will have to save it to your desktop instead.

There you should check it has been saved as file  and NOT .txt  by going to your Explorer window
and View > Show > File Name Extensions . Check your hosts file name, if it says hosts.txt  you
need to remove the .txt  and agree to the changes. You then cut and paste it back into your etc folder,
saying yes to replace your existing hosts file.

This should fix the looping and bring CC to its default behaviour. However, it will also be open to the
internet, which may cause issues for the apps currently installed.

If it happens, do Option 2 and create an Outbound rule for the programs .exe  malfunctioning.

 

Reverse Firewall Rule:

Windows > Windows Firewall > Advanced Settings

Check both Inbound and Outbound

Disable or remove any rules applied to ADOBE or other firewall rules you created or asked for in the
guides.

 

If neither of these has fixed the issue,

Please uninstall everything to the max using ☢️ Guide #4 - NOTHING IS WORKING / FULL CLEANING
and restart the respective guide you were doing from the beginning. This should ensure a clean slate.

If it’s still not working, let us know - but please be specific on:

What method do you have? (GenP or Monkrus);

Which of these fixes didn’t work;

What problem still happens;
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➜ Restore AppsPanel (vanilla)

Only if you want to restore from the previously made backup and move into official paid functionality, use the
following command:

cp "C:\Program Files (x86)\Common Files\Adobe\Adobe Desktop 

Common\AppsPanel\AppsPanelBL.dll.bak" "C:\Program Files (x86)\Common 

Files\Adobe\Adobe Desktop Common\AppsPanel\AppsPanelBL.dll"

If no errors are printed to the console, restart your machine. Upon startup, Creative Cloud will be returned to
normal functionality—

 

 

🛟 ❮ Return to r/GenP

☠️ ❮ Return to Wiki

Last revised by Mean-Plantain-7909 1 day ago
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